Custom Script TLS issue

Tags: 

Hi All,

I ran the TLS 1.0 Log Scanner tool and the result shows that is there TLS 1.0 traffic in the "Custom PHP "

What are the next steps to follow in order to solve it?

In Agent desktop, I am facing the TLS issue in the custom script PHP code.So I have added the below code in my php code.

but its not working.

Any help will be useful

<script>
var TLSWarningYUI,
displayWarning = function(data) {
if( data && data.tls_version.split(' ')[1] < 1.1 ){
var devHeaderPanel = TLSWarningYUI.one("#rn_DevelopmentHeader");
if(devHeaderPanel)
devHeaderPanel.setStyle("top", "25px");
var warningNode = TLSWarningYUI.Node.create(
'<div id="oldtlswarning" style="background:rgba(0, 0, 0, 0) none repeat scroll 0 0;color:red;text-align:center;top:0">'
+ 'Your browser lacks certain basic security requirements, You should upgrade your browser to the latest version.'
+ '</div>');

TLSWarningYUI.one("body *").insertBefore(warningNode);
}
};

YUI().use('node-base', 'node-core', 'node-style', 'panel','event-base', function(Y){
TLSWarningYUI = Y;
});

</script>
<script src="https://www.howsmyssl.com/a/check?callback=displayWarning"></script>

Thanks,
Seethalakshmi

Zircon - This is a contributing Drupal Theme
Design by WeebPal.