CXDev Toolbox 2.0 Now Available

The CXDev Toolbox 2.0 is now available. Learn more about the update from the announcement article, or visit the CXDeveloper Store for more information.

Discussion Board

Custom Script TLS issue

Posted by Seethalakshmi on Thursday, April 6, 2017 - 12:20am
Seethalakshmi's picture

Hi All,

I ran the TLS 1.0 Log Scanner tool and the result shows that is there TLS 1.0 traffic in the "Custom PHP "

What are the next steps to follow in order to solve it?

In Agent desktop, I am facing the TLS issue in the custom script PHP code.So I have added the below code in my php code.

but its not working.

Any help will be useful

SOAP Request without Security Header

Posted by amrutha21 on Wednesday, April 5, 2017 - 2:47am

Hi All,

Is it not possible to execute a XML request in SOAP UI without Security Header?

By giving the username and password in the authorization section?

I tried the same by removing the 'Security Header' section from the code and giving the username and password in the Authorization block, but it throws an error 'Username token required'.

Sample script to delete province associated to countries

Posted by venkat on Thursday, March 23, 2017 - 1:27pm

Hi,
Can someone share sample PHP script to delete provinces associated to countries

I'm new! Just wanted to say hi!

Posted by Dave-TwinkleBob on Thursday, March 23, 2017 - 5:08am
Dave-TwinkleBob's picture

Hi

I'm both new here and new to CX development. I've recently been drafted in as a .Net and PHP developer with experience developing CRMs (most of that experience is with Sage SalesLogix, now known as InforCRM).

I'm slowly getting used to the way things work in the Customer Portal.

I'm working on a May 2016 system with CP2, although we're due an upgrade to the main system soon and we'll be looking at a CP upgrade in the near future.

encrypt() not working

Posted by prashant on Monday, March 20, 2017 - 1:46am
prashant's picture

I am using CPHP (Connect PHP) for this encryption.

$key = "ABCDEFGHABCDEFGH";
$iv = "0000000000000000";
$cipher = new Crypto\AES();
$cipher->Mode->LookupName = 'CBC';
$cipher->IV->Value = $iv;
$cipher->KeySize->LookupName = '128_bits';
$cipher->Padding->ID = 1;
$cipher->Key = $key;
$cipher->Text = $string;
$cipher->encrypt();

For the last line ($cipher->encrypt()) I am getting the output as :

Pages

Zircon - This is a contributing Drupal Theme
Design by WeebPal.